Error accesing the locations view

Incident Report for Fluid Attacks

Postmortem

Impact

At least one user experienced issues in the Locations view. The issue started on UTC-5 24-07-24 14:05 and was proactively discovered 2.1 hours (TTD) later by a staff member who reported through our help desk [1] that after closing a vulnerability during a reattack request and returning the Locations view, an error message appeared There is an error :(. The problem was resolved in 1.2 hours (TTF), resulting in a total window of exposure of 3.3 hours (WOE).

Cause

Certain values were committed in the reasons enum [2].

Solution

The values VERIFIED_AS_SAFE and CLOSED_BY_MACHINE were added to the Enum in the API schema, allowing the API to recognize these new states [3].

Conclusion

The lack of testing and failure to test changes locally led to the problem. Before making changes, the team will implement the necessary tests to prevent similar issues. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Jul 25, 2024 - 20:36 GMT-05:00

Resolved

The incident has been resolved, and the locations view can now be accessed normally.
Posted Jul 24, 2024 - 18:05 GMT-05:00

Identified

An error occurs in the locations view when a vulnerability is closed during a reattack request.
Posted Jul 24, 2024 - 16:42 GMT-05:00
This incident affected: Platform.