Visual inconsistencies in tables

Incident Report for Fluid Attacks

Postmortem

Impact

At least three users experienced a visual inconsistency within the platform. The issue started on UTC-5 11-12-24 16:48 and was proactively discovered 16 hours (TTD) later by a staff member who reported through our internal chat that an overlapping component was observed across different sections of the groups, causing a visual issue in the affected sections. The problem was resolved in 57.6 minutes (TTF), resulting in a total window of exposure of 16.8 hours (WOE).

Cause

A refactoring of the section header component caused the issue. During the refactoring, the component was updated to receive a string (the group's name) instead of a specific component as a property. As a result, the group selector component was moved to ensure the correct rendering of the selection modal. However, the mistake was that the group selector contained the modal and the selector that opened it, which led to the visual overlap [1].

Solution

To resolve the issue, the group selector component was modified by removing the selector and leaving only the modal that allows the user to select the group [2].

Conclusion

The issue affected the Platform’s interface, which made it difficult to detect with automated tests. Additionally, the problem was not observed in the ephemeral environment. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Dec 13, 2024 - 14:45 GMT-05:00

Resolved

An overlapped text is shown in some tables inside the platform.
Posted Dec 12, 2024 - 08:30 GMT-05:00