Issues closing events
Incident Report for Fluid Attacks
Postmortem

Impact

At least one internal user experienced issues when closing an event on the platform. The issue started on UTC-5 24-03-15 14:08 and was proactively discovered 2.9 months (TTD) later by a staff member who reported through our help desk [1] that when attempting to close events with the Access granted solving reason resulted in the error message There is an error :(. External users remained unaffected. The problem was resolved in 20.8 hours (TTF), resulting in a total impact of 2.9 months (TTR) [2].

Cause

The problem occurred due to incorrect mapping in the event resolution configuration. The system used Access granted instead of Permission granted for all Network access issues events. When selected, this caused an error that wasn’t properly handled, resulting in a generic error message and preventing event resolution [3].

Solution

A fix was implemented to prevent the generic error message from appearing, configuring a specific error message. Subsequently, the affected event types were identified by comparing the backend configuration with the frontend, and corrections were made to the frontend configuration to resolve the issue [4].

Conclusion

The similarity between Permission granted and Access granted led to a misconfiguration and deployment to production. Error handling was added to display clearer messages to users, and frontend tests were adjusted. Moving forward, measures will be implemented to compare backend and frontend configurations in testing to prevent such discrepancies in the future [4]. INFRASTRUCTURE_ERROR < MISSING_TEST

Posted Jun 13, 2024 - 11:05 GMT-05:00

Resolved
The incident has been resolved, and now events can be closed normally.
Posted Jun 12, 2024 - 11:25 GMT-05:00
Identified
Problems have been detected when attempting to close events with the `Access granted` solving reason.
Posted Jun 11, 2024 - 16:37 GMT-05:00
This incident affected: Platform.