Issues registering environments

Incident Report for Fluid Attacks

Postmortem

Impact

At least one user experienced issues when registering environments on the platform. The issue started on UTC-5 25-02-17 15:41 and was proactively discovered 2.7 days (TTD) later by one of our engagement managers who reported through our help desk [1] that when attempting to register URL-type environments accessed via ZTNA or Egress the platform returned an error. The problem was resolved in 5.2 hours (TTF), resulting in a total window of exposure of 3 days (WOE) [2].

Cause

The checkbox for setting whether an environment uses ZTNA or Egress was mistakenly assigned the incorrect value of yes [3].

Solution

The checkbox component was updated to make the value optional, and the predefined yes assignment for useZtna and useEgress was removed. This ensures that the value is only set when explicitly selected [4].

Conclusion

Tests were implemented to prevent similar issues in the future and ensure the correct functionality when registering environments with ZTNA or Egress access. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Feb 21, 2025 - 09:58 GMT-05:00

Resolved

The incident has been resolved, and URL environments can now be registered without issues.
Posted Feb 20, 2025 - 16:35 GMT-05:00

Identified

Users are experiencing issues when registering URL environments.
Posted Feb 20, 2025 - 14:47 GMT-05:00
This incident affected: Platform.