Issues cloning AWS repositories
Incident Report for Fluid Attacks
Postmortem

Impact

At least one group experienced issues when cloning AWS repositories. The issue started on UTC-5 24-01-17 22:15 and was reactively discovered 11.4 months (TTD) later by one of our engagement managers who reported through our help desk [1] that several repositories were failing to clone and displayed the message Failed to clone without message. The problem was resolved in 2.8 days (TTF), resulting in a total impact of 11.5 months (TTR) [2].

Cause

The cloning process for repositories hosted on AWS CodeCommit requires setting specific environment variables on the machine. When attempting to clone repositories hosted on other services, like GitHub, managing these variables became problematic and caused the cloning to fail [3].

Solution

The cloning logic was updated to ensure that repositories hosted on AWS CodeCommit are processed separately and sequentially, distinct from the other repositories being cloned [4].

Conclusion

The local testing was improved. The error message for this use case will be enhanced and an alternative authentication method for cloning logic, which avoids altering environment variables, is being discussed in a related issue [5]. INFRASTRUCTURE_ERROR < INCOMPLETE_PERSPECTIVE

Posted Dec 30, 2024 - 18:10 GMT-05:00

Resolved
The incident has been resolved, and AWS repositories are now cloning as expected.
Posted Dec 30, 2024 - 15:13 GMT-05:00
Identified
Issues have been identified when attempting to clone AWS repositories.
Posted Dec 30, 2024 - 12:02 GMT-05:00
This incident affected: Platform.