Docs access unavailable for authenticated users

Incident Report for Fluid Attacks

Postmortem

Impact

At least one user encountered an access failure where authenticated sessions were unable to load documentation content, resulting in server-side errors, while the same content remained fully accessible to unauthenticated users. The issue started on UTC-5 26-02-24 18:12 and was proactively discovered 57.6 minutes (TTD) later by a staff member who observed that authenticated users were unable to access documentation due to repeated server errors, indicating a problem with how the backend handled authenticated requests. No customer reports were received. The problem was resolved in 4.9 hours (TTF), resulting in a total window of exposure of 5.9 hours (WOE) [1].

Cause

The error was caused by content that the client expected to receive from the server but was never sent. The root cause was the complexity introduced by dynamic tag filtering from the UI, where the server had to reconstruct all existing documentation tags in order to enable filtering [2],[3].

Solution

Support for tag filtering from the UI was removed, while preserving the same functionality in the search bar. By reducing the use case to only displaying tags related to each article, server-side complexity was significantly reduced, and the bug was eliminated at its root [4].

Conclusion

By removing UI-based tag filtering, the issue was fully resolved, and the overall complexity of the tagging feature was substantially reduced. In the future, we will implement unit tests for Docs to proactively detect and prevent similar issues. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Feb 27, 2026 - 07:47 GMT-05:00

Resolved

The incident has been resolved, and authenticated users can now access the documentation content as expected. Access controls have been restored to normal operation.
Posted Feb 25, 2026 - 00:15 GMT-05:00

Identified

Authenticated users are currently unable to access documentation content despite having valid credentials, preventing them from viewing and using Docs as expected.
Posted Feb 24, 2026 - 21:19 GMT-05:00
This incident affected: Docs.