Issues with approving evidence in new findings
Incident Report for Fluid Attacks
Postmortem

Impact

Issues were detected when attempting to approve evidence in new findings. The issue started on UTC-5 24-10-17 22:45 and was proactively discovered 4.7 days (TTD) later by a member of the staff who reported through our help desk [1] that, upon approving evidence, the error message There is an error :( appeared. The problem was resolved in 21.3 hours (TTF) resulting in a total impact of 5.6 days (TTR) [2].

Cause

The platform could not update evidence due to an exception triggered when a new field in FindingEvidence caused conditional checks to fail, as existing records lacked the attribute [3].

Solution

The primary step was removing the conditional check validations, followed by running a migration to add the authorEmail field to existing evidence records [4].

Conclusion

The migration ensured all dates were standardized to ISO format, enabling a streamlined validation process. Now, updates check only the modified_date attribute instead of the entire record, reducing complexity and preventing similar approval issues going forward. DATA_QUALITY < INCOMPLETE_PERSPECTIVE

Posted Oct 25, 2024 - 11:03 GMT-05:00

Resolved
The incident has been resolved, and it is now possible to approve evidence in new findings without any issues.
Posted Oct 23, 2024 - 14:06 GMT-05:00
Identified
Issues have been detected when attempting to approve evidence in new findings.
Posted Oct 23, 2024 - 09:50 GMT-05:00
This incident affected: Platform.