General service disruptions

Incident Report for Fluid Attacks

Postmortem

Impact

An unknown number of users encountered the Fluid Attacks' official documentation, which was unavailable. The issue started on UTC-5 25-09-26 00:45 and was proactively discovered 5 minutes (TTD) later by one of our monitoring tools and staff members, indicating a disruption in this component. The problem was resolved in 1.2 hours (TTF), resulting in a total window of exposure of 1.2 hours (WOE) [1].

Cause

A system update introduced a change that reduced the limit on certain network connections. This prevented part of our infrastructure from communicating properly, which led to the disruption [2].

Solution

We updated the configuration to allow the affected component to connect directly, restoring normal communication and service availability [3].

Conclusion

To reduce the risk of similar problems in the future, we will adopt a safer process when updating critical systems by gradually migrating services to a duplicate environment. While this makes updates slower, it helps prevent disruptions that may only appear hours after a change. We will also continue to explore additional preventive measures. INFRASTRUCTURE_ERROR < IMPOSSIBLE_TO_TEST

Posted Sep 26, 2025 - 09:41 GMT-05:00

Resolved

The issue has been resolved, and all Fluid Attacks products are now fully available.
Posted Sep 26, 2025 - 01:30 GMT-05:00

Identified

Some Fluid Attacks products are experiencing availability issues. Click for details: https://availability.fluidattacks.com
Posted Sep 26, 2025 - 01:00 GMT-05:00
This incident affected: Platform and Agent.