Issues with cloning repositories via ssh
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of groups encountered issues while cloning repositories via SSH. The issue started on UTC-5 24-07-16 14:43 and was proactively discovered 1.9 hours (TTD) later by a staff member who reported through our internal chat that cloning errors were ocurring. The problem was resolved in 1.2 hours (TTF) resulting in a total impact of 3.1 hours (TTR).

Cause

Discontinuing the use of a function that parsed SSH URLs and removed the ssh:// prefix led to the inability to clone repositories properly [1].

Solution

Reverting the merge request that caused the problem was necessary to restore the functionality of repository cloning via SSH [4].

Conclusion

The lack of testing and failure to test changes locally led to the problem. The team will implement the necessary tests before making changes to prevent similar issues. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Jul 17, 2024 - 17:58 GMT-05:00

Resolved
The incident has been resolved, and now repositories are cloning successfully.
Posted Jul 17, 2024 - 17:39 GMT-05:00
Identified
Issues regarding cloning repositories via SSH have been detected on the platform.
Posted Jul 16, 2024 - 17:38 GMT-05:00
This incident affected: Platform.