Issues requesting reattacks in Essential plan groups

Incident Report for Fluid Attacks

Postmortem

Impact

At least one group under the Essential plan experienced issues when requesting a reattack. The issue started on UTC-5 25-02-07 16:49 and was reactively discovered 11.7 days (TTD) later by a customer who reported through our help desk [1] that the reattack button was disabled when attempting to request a reattack on vulnerabilities reported by Machine. The problem was resolved in 23.7 hours (TTF) resulting in a total impact of 12.7 days (TTR).

Cause

With the implementation of the new Locations table, the restriction allowing Essential groups to only reattack Machine vulnerabilities was applied in two ways: by disabling both the rows and the reattack button. However, due to the updated flow, only row disabling was necessary [2].

Solution

The restriction that disabled the reattack button was removed [3].

Conclusion

End-to-end testing flows should be implemented for groups under the Essential plan. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Feb 20, 2025 - 17:39 GMT-05:00

Resolved

The incident has been resolved, and reattack requests are working as expected.
Posted Feb 20, 2025 - 12:11 GMT-05:00

Identified

Users with groups under the Essential plan are experiencing difficulties requesting reattacks on vulnerabilities reported by Machine.
Posted Feb 19, 2025 - 15:45 GMT-05:00
This incident affected: Platform.