Partial outage in the Fluid Attacks DB portal

Incident Report for Fluid Attacks

Postmortem

Impact

At least one user experienced degraded performance when accessing db.fluidattacks.com. The issue started on UTC-5 26-02-09 23:43 and was proactively discovered 11.2 hours (TTD) later by a staff member, who reported through our internal channels that the docs site was responding significantly slower than expected. Only the performance of the documentation was affected; there was no total service outage, and no customer reports were received. The problem was resolved in 18.7 minutes (TTF), resulting in a total window of exposure of 11.5 hours (WOE) [1].

Cause

A highly complex MDX document parsing process to support tags in the new documentation system was introduced, which negatively impacted performance and led to slower response times [2].

Solution

As an immediate mitigation, the change was reverted to restore acceptable performance levels [3]. After availability was recovered, a new solution was implemented that handles MDX document parsing more efficiently by leveraging caching mechanisms and extracting only the required metadata [4].

Conclusion

As we continue stabilizing the documentation platform, we will introduce basic performance tests aimed at detecting and preventing similar performance regressions in the future. PERFORMANCE_DEGRADATION < MISSING_TEST

Posted Feb 11, 2026 - 14:54 GMT-05:00

Resolved

The issue has been resolved, and the portal is now fully operational.
Posted Feb 10, 2026 - 11:40 GMT-05:00

Identified

The Fluid Attacks DB portal is experiencing intermittent availability issues.
Posted Feb 10, 2026 - 11:07 GMT-05:00
This incident affected: Docs.