Error adding new environments in a group

Incident Report for Fluid Attacks

Postmortem

Impact

An unknown number of users experienced difficulties when adding environments to Git Roots. The issue started on UTC-5 24-03-14 14:16 and was reactively discovered 4.8 days (TTD) later by a client who reported through our help desk [1] that it was not possible to add environments to the roots. The problem was resolved in 8.1 hours (TTF), resulting in a total window of exposure of 5.1 days (WOE) [2].

Cause

The inability to add environments to a git root stemmed from a data inconsistency issue arising when environments were marked as deleted in the database instead of removed entirely. This prevented the creation of new environments with the same name due to existing records in the database [3].

Solution

The implementation was modified to allow deleted environments to be recreated in the database [4].

Conclusion

The oversight of recreating a previously deleted environment was not considered when making changes to the environment processing. As a result, new test cases have been added to the functional tests to prevent similar incidents in the future [5]. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Mar 20, 2024 - 18:21 GMT-05:00

Resolved

The incident has been resolved, and now the functionality to add new environments to a group is working correctly
Posted Mar 19, 2024 - 18:52 GMT-05:00

Identified

It is not possible to add environment URLs to Git Roots.
Posted Mar 19, 2024 - 11:12 GMT-05:00
This incident affected: Platform.