Vulnerabilities view not loading

Incident Report for Fluid Attacks

Postmortem

Impact

An unknown number of users experienced issues when accessing the Vulnerabilities section, where the information failed to load as expected. The issue started on UTC-5 26-01-23 13:47 and was proactively discovered 57.6 minutes (TTD) later by an automated code analysis process and later corroborated by reports from staff members and clients. The problem was resolved in 43.2 minutes (TTF), resulting in a total window of exposure of 1.6 hours (WOE) [1].

Cause

A typing mistake caused a variable to be assigned an unexpected data structure. This mismatch led to a failure when the system attempted to retrieve information from the search service, resulting in errors that blocked the display of findings [2].

Solution

The code was corrected to ensure the variable is assigned using the expected format. This allowed the system to properly construct the request and successfully retrieve the required data [3].

Conclusion

The incident underscored the importance of stronger safeguards around data handling in search queries. As a result, improvements will be made to enforce stricter typing and reduce the likelihood of similar issues affecting users in the future.  INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Jan 23, 2026 - 17:18 GMT-05:00

Resolved

The incident has been resolved, and the vulnerabilities section is now loading correctly.
Posted Jan 23, 2026 - 16:03 GMT-05:00

Identified

The Vulnerabilities section fails to load correctly, preventing users from accessing and reviewing vulnerability information within the platform.
Posted Jan 23, 2026 - 15:40 GMT-05:00
This incident affected: Platform.