Menu items not working on webpage

Incident Report for Fluid Attacks

Postmortem

Impact

An unknown number of users found that the website’s menu items were not working. The issue started on UTC-5 24-03-05 09:53 and was proactively discovered 2.8 hours (TTD) later by a staff member who reported through our help desk [1] about an issue with the website's navigability. The problem was resolved in 1.6 hours (TTF), resulting in a total window of exposure of 4.5 hours (WOE) [2].

Cause

The components responsible for the website's functionality were not working correctly. This occurred due to an error when importing a library being added [3].

Solution

The library import was rectified [4].

Conclusion

The absence of targeted tests for the website allowed the error to remain undetected throughout the development process. Steps will be taken to implement comprehensive testing covering all functionalities and ensure application performance verification at each development stage. Therefore, an issue was created to implement such tests [5]. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Mar 05, 2024 - 16:23 GMT-05:00

Resolved

The incident has been resolved, and the menu items are now working correctly.
Posted Mar 05, 2024 - 14:54 GMT-05:00

Identified

The drop-down menu type items on https://fluidattacks.com website are not working.
Posted Mar 05, 2024 - 14:31 GMT-05:00
This incident affected: Web.