Issues registering Azure and GCP CSPM environments
Incident Report for Fluid Attacks
Postmortem

Impact

At least two groups encountered issues while registering environments for Azure and GCP. The issue started on UTC-5 24-12-17 14:14 and was reactively discovered 9.7 days (TTD) later by a client who reported through our help desk [1] that the platform displayed an error when attempting to complete the registration. The problem was resolved in 4 hours (TTF), resulting in a total impact of 9.9 days (TTR) [2].

Cause

An error in the CSPM environment verification process affected the ability to add new Azure and GCP environments. This issue arose from a misconfiguration in the interaction with the external APIs used for validation [3].

Solution

The process used to validate environments was updated to work correctly with the external cloud provider APIs, ensuring smooth and accurate registration of new environments [4].

Conclusion

More robust tests will be implemented to ensure that future adjustments to this functionality do not disrupt the registration process. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Dec 30, 2024 - 15:59 GMT-05:00

Resolved
The incident has been resolved, and environments can now be successfully registered on the platform.
Posted Dec 27, 2024 - 12:55 GMT-05:00
Identified
Issues have been identified when registering Azure and GCP CSPM environments on the platform.
Posted Dec 27, 2024 - 09:00 GMT-05:00
This incident affected: Platform.