Platform perfomance degradation

Incident Report for Fluid Attacks

Postmortem

Impact

At least one user experienced issues while using the platform, as several tables were slow to load or did not display information correctly, sometimes showing errors. The issue started on UTC-5 26-01-29 21:53 and was proactively discovered 17.7 hours (TTD) later by a staff member who reported through our internal channels about unusual delays and failures when accessing different sections of the platform. Although no direct customer reports were received, the issue affected multiple users. The problem was resolved in 2.8 days (TTF), resulting in a total window of exposure of 3.5 days (WOE) [1].

Cause

A recently introduced filter was enabled by default and triggered a request that required more resources than expected. This caused the system responsible for retrieving data to become overloaded, which resulted in slow response times and errors across the platform [2].

Solution

The query used to retrieve location data was updated to be more efficient, reducing the load on the system and restoring normal platform behavior [3].

Conclusion

The incident has been resolved, and the platform is now operating normally. To prevent similar situations in the future, internal tools have been improved to help detect performance issues earlier, and additional improvements to this part of the system are planned to make it easier to maintain and enhance over time. PERFORMANCE_DEGRADATION < INCOMPLETE_PERSPECTIVE

Posted Feb 03, 2026 - 14:33 GMT-05:00

Resolved

The incident has been resolved, and platform response times have returned to normal, ensuring a smooth and consistent experience.
Posted Feb 02, 2026 - 01:45 GMT-05:00

Identified

Users are experiencing high response times when accessing https://app.fluidattacks.com.
Posted Jan 30, 2026 - 16:32 GMT-05:00
This incident affected: Platform.