White screen at entering into Platform
Incident Report for Fluid Attacks
Postmortem

Impact

An unknown number of users experienced issues when trying to access the platform. The issue started on UTC-5 24-05-09 11:55 and was proactively discovered 1.2 hours (TTD) later by a member of the product team, who reported through our internal chat that the platform was not loading and displaying a white screen upon login. The problem was resolved in 57.6 minutes (TTF) resulting in a total impact of 2.1 hours (TTR) [1].

Cause

Alterations in how the organization item was structured in the local storage resulted in unexpected behavior. These changes caused issues for users who still had the old structure stored, leading to problems with the platform’s functionality [2].

Solution

At the moment, a revert of the commit that introduced the issue was performed [4].

Conclusion

The problem arose because the platform could still function with the new local storage structure, allowing all tests to pass. The name of the local storage item was replaced to enforce the use of a new item with its new structure, ensuring compatibility with the updated local storage structure. INCOMPLETE_PERSPECTIVE

Posted May 09, 2024 - 17:10 GMT-05:00

Resolved
The platform is now operating normally.
Posted May 09, 2024 - 16:00 GMT-05:00
Update
We are continuing to work on a fix for this issue.
Posted May 09, 2024 - 14:09 GMT-05:00
Identified
The platform is experiencing a partial outage when attempting to log in.
Workaround: clearing browser's localStorage. With a blank screen, enter the developer console mode of the browsers (usually accessed by pressing F12 or right-clicking and choosing the "Inspect" option), then navigate to the "Application" tab, proceed to the "Local Storage" option, and delete the one related to app.fluidattacks.com.
Posted May 09, 2024 - 14:06 GMT-05:00
This incident affected: Platform.