Inconveniences at adding git roots in a group
Incident Report for Fluid Attacks
Postmortem

Impact

At least one group encountered issues adding new git roots via ZTNA into the Scope section of the Platform. The incident was reported proactively. The issue started on UTC-5 22-09-13 15:28 and was proactively discovered 14.3 months (TTD) later by a member of the experience team who reported it through our help desk [1], while setting up a PoC. The problem was resolved in 3.7 days (TTF) resulting in a total impact of 14.4 months (TTR).

Cause

The problem originated during a migration, which did not consider inactive elements within the organization due to group deletion. The migration focused only on active group elements, leaving out the roots of the deleted groups. Consequently, these group roots missed out on receiving the new attributes [2].

Solution

The team performed a new migration to add the missing data to the incomplete git roots [3].

Conclusion

Currently, there is no way to test this type of migration to ensure the completeness of the data, making it prone to overlooking crucial elements, as observed in this instance. The team is developing new strategies to guarantee the integrity of the data after any migration to avoid these issues. DATA_QUALITY < FAILED_MIGRATION < MISSIGN_TEST

Posted Nov 20, 2023 - 13:42 GMT-05:00

Resolved
The incident has been resolved, and now the addition of git roots works correctly.
Posted Nov 20, 2023 - 12:26 GMT-05:00
Identified
Some problems were noticed when trying to add git roots to some groups via ZTNA.
Posted Nov 17, 2023 - 11:15 GMT-05:00
This incident affected: Platform.