Evidence upload issue
Incident Report for Fluid Attacks
Postmortem

Impact

At least one user encountered difficulties accessing the evidences from the Findings. The issue started on UTC-5 24-12-19 11:57 and was proactively discovered 1.9 hours (TTD) later by a staff member who reported through our help desk [1] that the Findings evidences were not loading as expected. The problem was resolved in 3.3 hours (TTF) resulting in a total impact of 5.2 hours (TTR) [2].

Cause

The locations and vulnerabilities URLs were changed, but the evidence routes were not updated accordingly. As a result, while the evidence files were still stored in the system, they were no longer accessible to users. This happened because the same route was being used for both Events and Locations, and the impact of the URL change on the locations view was not properly considered [3].

Solution

The system's routing structure was reorganized to handle the display of evidence of events and locations separately. This ensures that each section has its own specific path, preventing evidence from becoming inaccessible [4].

Conclusion

The tests did not fail because the evidence was still being loaded, but they displayed the alt text instead of the intended file. This particular scenario had not been previously tested. To address this, tests were updated with visual validations to ensure the files were displayed correctly. Additionally, an alert mechanism was implemented to report if a similar issue arises in the future. INCOMPLETE_PERSPECTIVE < MISSING_TEST

Posted Dec 23, 2024 - 08:28 GMT-05:00

Resolved
The incident has been resolved, and evidences are now loading correctly.
Posted Dec 19, 2024 - 18:40 GMT-05:00
Identified
Issues have been identified when loading evidence linked to findings, preventing their proper display.
Posted Dec 19, 2024 - 14:12 GMT-05:00
This incident affected: Platform.