Issues with sending analysts' progress reports
Incident Report for Fluid Attacks
Postmortem

Impact

At least one staff member reported issues receiving the progress report. The issue started on UTC-5 24-07-30 19:06 and was proactively discovered 20.8 hours (TTD) later by a staff member who reported through our help desk [1] that the reports had not arrived as usual. The problem was resolved in 1 day (TTF) resulting in a total impact of 1.8 days (TTR) [2].

Cause

An email was added to the environment variables as part of the mailing list but entered incorrectly as a single string separated by commas. The system that sends the emails didn’t know how to split this string into individual email addresses. As a result, it couldn’t recognize any addresses, which prevented the email from being sent [3].

Solution

Formatting the string allowed for the extraction of email addresses, and treating them as a list was the solution. This ensures successful email delivery [4].

Conclusion

This incident underscores the need to handle data inputs carefully to ensure smooth system functionality. INCOMPLETE_PERSPECTIVE

Posted Aug 02, 2024 - 13:48 GMT-05:00

Resolved
The incident has been resolved, and progress reports are now being sent successfully.
Posted Aug 01, 2024 - 19:09 GMT-05:00
Identified
Problems have been identified with sending progress reports to analysts.
Posted Aug 01, 2024 - 14:06 GMT-05:00
This incident affected: Platform.